Condividi
Andare in basso
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

CK2III per bassa impedenza

il 26/1/2013, 23:18
Siccome sono quasi in dirittura d'arrivo, vi racconto un po' l'evoluzione di questo progetto.
Premetto che ho preso il saldatore in mano solo da questo mese, ma la cosa più difficile per me sono i collegamenti di alimentazione e il lavoro duro col metallo.

Quest'ampli oppure la sua versione originale (dopo spiego le differenze) erano nella lista dei papabili. Circa 9 mesi fa trovo un'occasione: un Ck2III già montato, configurato come pre (=basso bias), con componenti di qualità e alimentato con un'ottima psu stabilizzata di tipo serie, la sigma22.
Ci penso qualche giorno e poi lo prendo. Me lo faccio collegare da un caro amico, alimentazione flottante (per mancanza di case). Notare che l'anno scorso le mie conoscenze erano solo teoriche, e ora non sono molto meglio ;)
Lo accendiamo assieme, poggiato semplicemente in una scatola di cartone, dov'è ancora. Anche se era stato in funzione in precedenza, l'emozione era forte. Ci collego le mie cuffie buone, le W1000X, e il piccoletto suona.
Ammazza se suona. E non c'è nemmeno un'ombra di rumore, nonostante l'assemblaggio posticcio.

Decido che il piccoletto, che chiamo Kumisa per semplicità e rifacendomi al nome originale, merita un bel case, un assemblaggio a regola d'arte, ma anche qualche miglioramento.
Il progetto originale prevedeva uno stadio di ingresso a bipolari, una diversa configurazione dell'opamp di servo, e lo stadio di uscita a inseguitore di emettitore.
La versione "C-K" prevede invece ingresso a jfet (matchati), l'opamp in modo più "stabile", ma uno stadio finale più prono ad oscillazioni quale il CFP, per ridurre la distorsione immagino, dato che il circuito è privo di controreazione globale.

Nei mesi che seguirono, ho ascoltato e/o posseduto vari ampli commerciali, e la preferenza è sempre andata per lo scatolotto di cartone :D
Quindi bisognava migliorarlo. Due erano le cose fondamentali: alzare la polarizzazione fino ad almeno 100mA, e sostituire i finali con dei transistor di media potenza "qualitativamente migliori". L'aggiustamento del bias si rivela sostanzialmente impossibile, il busillis non è stato trovato, questo mi spingerà alla fase due. La prova di transistor finali diversi invece si rivela una scelta vincente, tanto quanto onerosa (in termini di tempo) per il mio amico (4 basette, 6 switch a 3 poli recuperati in Polonia, e cavi a go-go).
Le quattro coppie di finali in prova sono:
BD140/139 - la scelta di default , che erano già montati
MJE243/MJE253 - consigliati dal "produttore" come alternativa testata
2SC2238Y/2SA968Y (Magnatec) - che godono di ottima reputazione
2SB1186A/2SD1763A (Rohm e ISC) - perché anche se leggermente inferiori ai precedenti sulla carta, erano usati nel progetto originale

NB: Nessuna selezione stata fatta dei transistor perché non disponevo di tester ed anche perché ho acquistato solo pochi pezzi in più.

Il mio amico non sente differenze, io invece col mio setup e dele tracce che conosco a memoria, le noto eccome. I MJE sono molto simili ai BD, ma ancora più grezzi e aspri. Le altre due coppie invece... portano l'ampli ad una classe superiore. La scelta tra i Toshiba e i Rohm si consuma dopo non meno di un paio di mesi di ascolti. Con alcune tracce la mia preferenza andava per gli uni, con altre per gli altri, rendendo la scelta difficilissima. Alla fine i Rohm hanno avuto la meglio, per un suono più veritiero rispetto alla sorgente.
Ignoro il matching casuale che è capitato tra i transistor usati, ma nell'accoppiamento in CFP coi BC550/60 questo è stato il risultato.
Nonostante il groviglio di cavi e piste di stagno, continua a non sentirsi alcun rumore di fondo(!).
Se qualcuno insiste posto la foto, ma mi vergogno un po' :D

E' restato il cruccio del bias. Nei passaggi più forti la preoccupazione della distorsione di crossover non mi faceva godere la musica :) invece mi è (fortunatamente) passata la voglia di provare ancora altri finali. C'erano in programma persino dei fet laterali, che avrebbero richiesto pesanti modifiche al circuito.
La soluzione che ho optato è stata di ripartire da zero.
Nuovo PCB, assemblaggio autonomo, per non dover attendere la grazia altrui (e per imparare, finalmente).
Diversi mesi e numerosi acquisti di attrezzi e strumenti dopo, mi trovo con una nuova scheda quasi completamente popolata, un'altra PSU identica, un bel case spazioso (e perfettamente identico al mio dac, ma quello è un altro discorso).
Notare che è uno stampato parecchio denso e che qualche saldatura l'ho dovuta aggiustare.
Sono partito coi valori giusti di resistenze e condensatori, calcolati per il guadagno minimo di 4,1x e ben 150mA di bias.

Decido in corso d'opera di provare la configurazione del circuito originale. Se la scelta dei finali era azzeccata, e non dettata solamente dalla difficoltà degli stessi di oscillare, vuoi vedere che tutto il circuito rende meglio con l'OPS ad emitter-follower?
Lascio quindi le resistenze di emettitore dissaldate, e decido di provare prima l'EF.
Poi, questa era l'occasione giusta per confrontare le due configurazioni, con due ampli praticamente identici, e con le cuffie.

Nel frattempo, ho recuperato un discreto stock di transistor originali Rohm (che io sappia non ci sono fake, ma cmq il fornitore è affidabile), ne misuro Hfe e Vgs, e riesco a trovarne una quartetta matchata (su 32). Purtroppo sono di classe di guadagno diversa, i NPN non si trovano più di classe Y.
Monto i piloti sul pcb del CKK, anche qui utilizzo i transistor originali, che sono più robusti e hanno guadagno molto più BASSO dei BC (per intenderci 180 contro 550), anche questi matchati al 10% (mi è andata un po' meglio).
Ora mentre sono in attesa dei collegamenti (creare collegamenti al volo su millefori e sbrogliare le piste sono ancora cose troppo difficili per me), sto studiando il layout nell'ottimo case che ho recuperato. Ho deciso di usare un dissipatore leggermente più grande di quello in mio possesso, quindi sono in attesa anche di quello.

Nel secondo post metto qualche foto, qui ho scritto anche troppo.

Ovviamente alla fine, ci saranno un po' di ascolti comparativi e l'ampli perdente verrà messo in vendita.
Poi finalmente posso passare al prossimo progetto e la lista è bella lunga (il VHF è al terzo posto).

(continua)
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 26/1/2013, 23:28
(...continua)

Foto dei finali durante la selezione:




Foto delle saldature:


Layout 1:


Layout 2:


Il primo layout è leggermente meglio per i percorsi del segnale, ma il secondo sfrutta le ferritoie del case per far uscire il calore del dissipatore (montato più a destra di come è nella foto e cmq quello è il dissy che è stato scartato, quello nuovo avrà le "grate" in verticale).

Notare il bellissimo pcb per potenziometro alps blue/noble, i cui collegamenti volanti sono una faticaccia. Jack, led e presa IEC non sono stati montati, i dissipatori dei mosfet della psu non erano ancora saldati. Il portafusibile necessita di un'allargatina ad uno dei fori in altro a destra sul retro del case e non l'ho ancora fatto.
infine, in caso estremo posso tagliare parte del pcb che contiene l'alimentazione inutilizzata.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 7/2/2013, 13:02
Complimenti, il Cavalli-Kumisa è un progetto molto interessante (soprattutto la parte di ingresso con il doppio triodo). Daremo insieme un'occhiata allo schema elettrico...
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 7/2/2013, 13:03
@bandAlex ha scritto:Complimenti, il Cavalli-Kumisa è un progetto molto interessante (soprattutto la parte di ingresso con il doppio triodo). Daremo insieme un'occhiata allo schema elettrico...

Quale triodo? :)
lo stadio di ingresso è un classico differenziale (a jfet in questo caso)
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 7/2/2013, 13:16
Hai ragione... nella mia testa ero convinto fosse questo:
http://www.cavalliaudio.com/diy/soha%20ii/main.php?page=design/ipdesign

cioè il SOHA II, progetto che ovviamente non ha niente a che vedere con il CK2III... grande sorriso

Comunque, anche il CK2 è interessante.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 7/2/2013, 13:26
Questo è lo schema elettrico del CK2III:
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 7/2/2013, 13:41
Quello che hai postato tu è lo schema del CK2II, si.

Qui di seguito lo schema originale:


e questo è il CK2III dopo le varie modifiche di Cavalli e Ti Kan (solo un canale mostrato):


Ora le modifiche che ho già fatto sono state:
-alimentazione stabilizzata di qualità (molto) superiore
-guadagno al "minimo", cioè x4.1
-bias a 170mA (presto vedremo se funziona)
-drivers toshiba (vedi lo schema originale per i modelli)
-finali Rohm (anch'essi dello schema originale, dopo aver provato altri 3 tipi)
e la "novità" rappresentata dai finali configurati a "banale" emitter-follower

Restano valide -anche avendo quei pcb- il setup del servo e lo stadio di ingresso a jfet anziché a bipolari.

I dissipatori sono arrivati solo oggi, e nel weekend il mio amici mi sistema i finali su basetta e li aggancia al dissy, quindi la settimana prossima dovrei essere pronto per testare tutto.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 7/2/2013, 13:42
@Telstar ha scritto:Quale triodo? :)
lo stadio di ingresso è un classico differenziale (a jfet in questo caso)

Quale differenziale? :)
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 7/2/2013, 13:58
@bandAlex ha scritto:
@Telstar ha scritto:Quale triodo? :)
lo stadio di ingresso è un classico differenziale (a jfet in questo caso)

Quale differenziale? :)

err.. mezzo differenziale? :D
Mi sa che devo riaprire l'Horowitz :(
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 7/2/2013, 14:23
@Telstar ha scritto:
e la "novità" rappresentata dai finali configurati a "banale" emitter-follower

Sono d'accordo con la scelta di utilizzare il "banale" EF al posto del CFP.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 7/2/2013, 16:56
@bandAlex ha scritto:
@Telstar ha scritto:
e la "novità" rappresentata dai finali configurati a "banale" emitter-follower

Sono d'accordo con la scelta di utilizzare il "banale" EF al posto del CFP.

Bene, questo mi conforta.
Poi vedrò se posso fare a meno di quei condensatori di "stabilizzazione" C8 e C9, o magari usarne più piccoli a film.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 7/2/2013, 17:04
@Telstar ha scritto:Poi vedrò se posso fare a meno di quei condensatori di "stabilizzazione" C8 e C9, o magari usarne più piccoli a film.

In teoria, se usi la configurazione EF dei finali come hai detto, quei condensatori non dovrebbero esserci (e nemmeno R20 e R22)...
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 7/2/2013, 17:07
@bandAlex ha scritto:
@Telstar ha scritto:Poi vedrò se posso fare a meno di quei condensatori di "stabilizzazione" C8 e C9, o magari usarne più piccoli a film.

In teoria, se usi la configurazione EF dei finali come hai detto, quei condensatori non dovrebbero esserci (e nemmeno R20 e R22)...

Le resistenze le ponticello, I condensatori prima provo, oscilloscopio alla mano. Ma guardando lo schema originale (qualche post più sopra,quello blu-verde), come dici tu, entrambi dovrebbero andar via. :)
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 12/2/2013, 21:24
Allora, purtroppo non tutto è andato liscio come l'olio :(
Riporto quel che mi ha detto l'amico che ha montato i finali l'altro giorno.
Abbiamo usato un alimentatore in DC variabile (da 2.5+2.5 a 12+12V).


"Acceso gradualmente, fino a 9+9 volt il circuito non ha dato nessun segno particolare
di vita tranne il fatto che il doppio op-amp azzerava correttamente gli offset
su entrambi i canali. Non appena ha superato i 10+10 volt ha comiciato a
scaldare sempre più fino ad arrivare (ieri sera) quasi a scottare (che
significa sul dissipatore una temperatura superiore ai 50-60 °C) e
l'offset di uno solo dei canali ha cominciato ad andare per i fatti suoi.

Ieri sera poi ho ripetuto un paio di volte il passaggio per vedere
come si comportava l'alimentatore... e fino a 18 Volt (9+9) non ha fatto
una piega ma come ha superato i 20 volt (10+10), i led
dell'alimentatore si sono messi a lampeggiare segno sicuro di
sovraccarico (è una "funzione" nata per caso ma rivelatasi molto
utile!). Il mio alimentatore è in grado di tirare fuori 2 ampere
continui senza problemi.

I trimpot erano al minimo (che in questo circuito
significa averli al valor massimo) ma i finali scaldavano di brutto lo
stesso. Ho poi provato ieri sera a variare i trimpot e su entrambi i
canali la corrente che passa nei finali non viene minimamente
controllata; ma mentre il canale "sano" mostra una polarizzazione quasi
nulla (una manciata di millivolt sulle resistenze di uscita che
signficano qualche milliampere al massimo) sul canale presumibilmente
infortunato mostra quasi mezzo volt, corrispondente a quasi un ampere di
uscita. Inoltre quest'ultimo canale a toccargli l'ingresso è
completamente sordo (l'oscilloscopio non rileva nulla sull'uscita)
mentre l'altro qualche segnale di vita, sia pure molto asfittico, lo da."


Lui punta il dito sui jfet di ingresso, io sui predriver (BC550C/560C al posto dei BD135/136 usati nel progetto originale), o eventualmente qualche altro bipolare di segnale morto in partenza. Non li ho testati tutti prima di montarli (perché non mi era ancora arrivato il tester). Di J74/K170 morti/delicati non me ne ricordo molti in verità, ed essendo un set matchato mi girerebbero alquanto se ci fosse stato qualcuno difettoso.

Adesso, dissalderemo i jfet e li testiamo, nonché testeremo anche i vari BC, e molto probabilmente i prepiloti saranno cambiati. Ho in casa i BD 139/140, e proveremo quelli.

Alex, se hai qualche suggerimento, sei il benvenuto.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 13/2/2013, 10:12
Posso darti un consiglio, fai le misure di tensione senza il servo-dc, cioè togli prima dallo zoccoletto entrambi gli opamp. In questo modo avrai le misure sul circuito senza che questo venga influenzato dai tentativi del servo-dc di correggere l'offset. Misurerai quindi per prima cosa quanto vale la tensione continua presente all'uscita (anche senza servo-dc essa non deve essere troppo alta, diciamo non deve superare i 2V). Se l'uscita è agganciata a uno dei due rail, allora è sicuramente presente un guasto a livello di semiconduttori (giunzione danneggiata oppure transistor montato al rovescio, etc.).

Con il trimmer regolato per il minimo di corrente i finali non devono scaldare eccessivamente, ma rimanere quasi freddi. Se invece scottano, allora la corrente di riposo è sballata, e ciò può dipendere da un danno ai finali stessi, oppure al Vbe multiplier (il BC550 tra le basi dei finali).

Controlla che i transistor siano stati tutti montati nel verso giusto. A scheda spenta, controlla le giunzioni b-e. Non è necessario dissaldare i componenti, semplicemente con il tester impostato per il controllo dei diodi, verifichi che in un verso la giunzione ti dia circa 0.6/0.7V. Se così è allora il transistor in questione funziona.

Per controllare la corrente di riposo puoi misurare la tensione ai capi delle due resistenze in serie da 0.5 (totale 1 ohm). Il valore misurato ti darà direttamente il valore di corrente in ampere.

avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 13/2/2013, 10:18
@Telstar ha scritto:
@bandAlex ha scritto:
@Telstar ha scritto:Poi vedrò se posso fare a meno di quei condensatori di "stabilizzazione" C8 e C9, o magari usarne più piccoli a film.

In teoria, se usi la configurazione EF dei finali come hai detto, quei condensatori non dovrebbero esserci (e nemmeno R20 e R22)...

Le resistenze le ponticello, I condensatori prima provo, oscilloscopio alla mano. Ma guardando lo schema originale (qualche post più sopra,quello blu-verde), come dici tu, entrambi dovrebbero andar via. :)

Se hai usato la configurazione EF, ricordati che R20 e R22 NON devono esserci (quindi NIENTE ponticelli, altrimenti è come se usassi una R di valore 0, cioè un cortocircuito, e in tal caso il circuito non può funzionare).
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 13/2/2013, 11:09
@bandAlex ha scritto:Se hai usato la configurazione EF, ricordati che R20 e R22 NON devono esserci (quindi NIENTE ponticelli, altrimenti è come se usassi una R di valore 0, cioè un cortocircuito, e in tal caso il circuito non può funzionare).

No, tranquillo, non ci sono. E neppure i due condensatori. E l'oscilloscopio dice che non ci sono oscillazioni, il problema è a monte.
Non ci ho lavorato io sulla basetta, ma una persona molto più esperta di me, a cui cmq giro il tuo post precedente, visto che stasera farà altre prove.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 13/2/2013, 19:42
@bandAlex ha scritto:Posso darti un consiglio, fai le misure di tensione senza il servo-dc, cioè togli prima dallo zoccoletto entrambi gli opamp.

E' un opa doppio, cmq ottimo suggerimento quello di testare (a bassa tensione senza servo) faremo così e poi posto i risultati.

Se l'uscita è agganciata a uno dei due rail, allora è sicuramente presente un guasto a livello di semiconduttori (giunzione danneggiata oppure transistor montato al rovescio, etc.).

Transistor al rovescio lo escludo al 100%, sono stato attentissimo. Non escludo però di aver invertito un 550 con un 560, oppure alcuni erano DOA. CMQ li testiamo stasera e vediamo.

Con il trimmer regolato per il minimo di corrente...

Sti cazzo di trimmer Vishay non sembrano funzionare per niente.
Ne avevo altri due in casa dello stesso batch e mi sono preso la briga di misurarli con un resistometro (tra i pin esterni).

Il primo misura 1,088K e il secondo 1,040k. La vite di
aggiustamento NON sembra funzionare su nessuno dei due. Dovrebbero
avere 25 giri ma vanno all'infinito, come giro e giro, non cambia nulla nella misura.

Avevamo lo stesso problema di bias sull'altro CKK che guardacaso ha gli stessi identici trimmer. La cosa mi puzza parecchio...

Per controllare la corrente di riposo puoi misurare la tensione ai capi delle due resistenze in serie da 0.5 (totale 1 ohm). Il valore misurato ti darà direttamente il valore di corrente in ampere.

E' quello che ha fatto il mio amico, e mentre canale aveva pochi mA, l'altro quasi mezzo A.


Ultima modifica di Telstar il 13/2/2013, 19:43, modificato 1 volta (Motivazione : spelling)
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 14/2/2013, 15:24
Allora, ieri sera abbiamo tolto l'operazionale (grazie per la dritta Alex!).
[In corsivo tra parentesi quadre i miei commenti.]

Con 11+11V di alimentazione, è rimasto l'offset
(consistente ma niente di tragico: circa 2 volt per entrambi i canali
segno che i FET sono stati veramente accoppiati ma solo per quelli della
stessa polarità) e se ne è andato il comportamento "pazzo" dei finali che
diventavano una stella nova (ora rimangono interdetti... come è giusto
che sia visto l'insufficienza del VBE multiplier).


Tuttavia qualcosa continua a non andare nel senso che i piloti
scaldano come se pilotassero a piena potenza quando in realtà non stanno
facendo niente (gli ingressi sono in corto).
[Fortunatamente i toshiba sono belli resistenti, se avessi usato i BC probabilmente si sarebbero fritti]

Qualcosa evidentemente
oscilla addirittura a frequenze non rilevabili con oscilloscopio e sonde
standard (devo trovarne una buona per RF
[Forse ce l'ho io, oppure la compro, e sto pensando di prendere anche un generatore di impulsi/onde quadre]

Di buono vi è
che questo chiude la questione sui possibili BC, SK ecc. andati arrosto:
i componenti sono a posto (i due canali funzionano entrambi male ma
nello stesso modo) ed è invece il circuito che è da rivedere meglio.
[Bene, almeno non ho cannato con le saldature e il montaggio! :)]


Sul problema del servo collegato con la polarità sbagliata
(invertente anziché non invertente) ce la si cava con poco (occorre
scambiare tra loro Q5 e Q6 e, di questi, scambiare tra loro collettore
ed emettitore in modo che diventino un invertitore anziché un

inseguitore come sono adesso).
[Prima metterei l'opa2134 come entrambi progetti e poi rivediamo le oscillazioni]

***
I prossimi step saranno:
1) sostituzione dei prepiloti con i BD135/136, i BC sono troppo veloci/hanno troppo guadagno;
2) installazione dell'OPA corretto, e POI provare la configurtazione non invertente (vedi schema originale);
3) infine, ricalcolare il VBE multiplier per dare una corrente sufficiente ai finali, e non ai piloti;
Ad ognuno di questi step controllare con l'oscilloscopio (e sonda adeguata)
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 14/2/2013, 15:34
A 'sto punto devo capire bene quale circuito avete adottato tra quelli inseriti nel thread, perchè non mi tornano alcune cose. Magari se lo metti qui sotto si chiarisce bene la questione. wink
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 14/2/2013, 16:12
@bandAlex ha scritto:A 'sto punto devo capire bene quale circuito avete adottato tra quelli inseriti nel thread, perchè non mi tornano alcune cose. Magari se lo metti qui sotto si chiarisce bene la questione.

Questo schema poiché questo è il pcb che ho:

Con queste differenze:

-R12, R13 : 825 Ohm
-C5, C6 22pF
-piloti 2SC2705/2SA1145
-finali 2SD1763/2SB1186 (nessuna cella di compensazione)

Sto preparando lo schema in spice e facendo qualche simulazione, ma mi mancano i modelli dei finali, forse è pronto stasera.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 14/2/2013, 19:47
Seppur mancando i modelli dei transistor usati come piloti e finali, questa è la schermata di ltspice in cui sto simulando il circuito con i valori usati (ma con l'opamp invertita altrimenti non funziona un bel niente col simulatore!)
CFP a sinistra e EF a destra, AC 1V, 20khz in ingresso, V(vout) plottato e zoomato per evidenziare la distorsione di crossover - chiaro segnale che i bias è insufficiente già con la configurazione standard. (dovrebbe essere un classe A)



C'è sicuramente da lavorare al simulatore prima di mettersi a saldare componenti con valori creativi.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 16/2/2013, 23:22
Montata oggi l'opamp originale. L'offset di ENTRAMBI i canali è sceso a 0.6V.

Intanto io col simulatore, per far sparire la distorsione di crossover ho dovuto ridurre R19 (dove c'è ora il trimmer) a <400 Ohm. Serve ancora di più per portare la FFT ad un livello accettabile (7a e 9a armonica sono ancora troppo alte cmq).

Allego immagine del cricuito simulato. Il beta dei modelli usati si avvicina a quello misurato, quindi il risultato dovrebbe essere abbastanza attendibile.

e
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 18/2/2013, 14:51
Anche qui come mi è capitato in passato, alzando leggermente la tensione di alimentazione migliora lo spettro armonico in spice.
Non so quanto questo sia attendibile nella realtà, ma se il mio amico finisce col mettere dei cascode ai jfet di ingresso, un'alzatina alla tensione di alimentazione gliela diamo.

Alex aspetto il tuo prezioso input :)
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5586
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 22/2/2013, 13:32
Come è andata a finire?
Contenuto sponsorizzato

Re: CK2III per bassa impedenza

Torna in alto
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum