Condividi
Andare in basso
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11

Re: CK2III per bassa impedenza

il 22/3/2013, 18:48
Dovrebbero essere invertiti gli ingressi dell'opamp o sbaglio? Poi dovrebbe essere ok.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 22/3/2013, 18:50
Per curiosità, prova pure la configurazione che ti ho detto io...
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 22/3/2013, 21:25
@bandAlex ha scritto:Dovrebbero essere invertiti gli ingressi dell'opamp o sbaglio? Poi dovrebbe essere ok.

In un verso o nell'altro, la DC in uscita è esattamente uguale
BTW la compensazione va aumentata almeno ad 1uF come mi hai suggerito tu, perché quell'OPA tendeva ad oscillare nel kumisa3.

Adesso provo le tue modifiche e riporto.
Ecco, l'offset è identico a prima al simulatore (ma cmq era buono, sui 3mV).


Il tuo punto 5 mi sembrava strano, e la resistenza l'ho collegata all'ingresso positivo dell'opamp.

Altra cosa: rimettendo il riferimento a massa vicino a C5/C6, scende il rumore di fondo a bassa frequenza (cioè sotto i 100khz) ma la distorsione resta inalterata, quindi in teoria meglio lasciarlo: commenti?
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 24/3/2013, 15:21
Il mio amico ritiene che la massa vicino al VAS renda instabile il punto di lavoro, la differenza è minima lasciandolo flottante, quindi ho deciso di toglierlo, e già che c'ero ho cambiato un paio di transistor coi bc550/560 di cui prenderò uno stock da matchare, e infine spostato le capacità da 1000uF più vicine all'alimentazione dei finali, e alzato C1/C2 a 47uF.
Sono soddisfatto del risultato. Il simulatore mi dice che R4 e R40 dovrebbero avere dei trimmer per aggiustarle sulla base dei transistor reali, perché basta poco per sbilanciare l'offset, e il servo non funziona troppo bene.
Se vuoi anche il file di spice per guardarlo meglio, te lo mando in mail.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 24/3/2013, 17:41
@Telstar ha scritto:Sono soddisfatto del risultato. Il simulatore mi dice che R4 e R40 dovrebbero avere dei trimmer per aggiustarle sulla base dei transistor reali, perché basta poco per sbilanciare l'offset, e il servo non funziona troppo bene.

Probabilmente il servo non funziona troppo bene perchè l'impedenza nel punto in cui applica la correzione è troppo bassa, e lui lavora al limite delle sue possibilità. Prova a vedere quanto è la tensione sull'uscita di U1. Se è troppo alta (maggiore di 10/12V) allora dovresti apportare una modifica per aumentare l'impedenza di quel punto (il punto di congiunzione tra R9 e R10).

Ma c'è un problema più importante secondo me, ed è che tu hai collegato insieme le basi di Q2/Q5 e Q3/Q6, ma in questo modo l'intervento del servo viene parzialmente annullato. Prova ad applicare il bias sulle basi di Q2 e Q3 separatamente, e vedi se il servo migliora la sua efficienza.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 24/3/2013, 22:57
@bandAlex ha scritto:Probabilmente il servo non funziona troppo bene perchè
l'impedenza nel punto in cui applica la correzione è troppo bassa, e
lui lavora al limite delle sue possibilità. Prova a vedere quanto è la
tensione sull'uscita di U1. Se è troppo alta (maggiore di 10/12V) allora
dovresti apportare una modifica per aumentare l'impedenza di quel punto
(il punto di congiunzione tra R9 e R10).

Macché, è piccolissima: -3.6mV.

Ma
c'è un problema più importante secondo me, ed è che tu hai collegato
insieme le basi di Q2/Q5 e Q3/Q6, ma in questo modo l'intervento del
servo viene parzialmente annullato. Prova ad applicare il bias sulle
basi di Q2 e Q3 separatamente, e vedi se il servo migliora la sua
efficienza.

Collego una batteria per vedere. Mah, non cambia niente riguardo all'offset. L'opamp sembra funzionare allo stesso modo.



Invece
ho fatto due altre prove, ho collegato l'opamp all'alimentazione (a
24V, o anche abbassata), anziché a massa, la fa funzionare meglio. MA il
rumore si alza esageratamente (da -110 a -60dB), a meno che non tolgo
il collegamento dove ho segnato in rosso

Se
lo tolgo, il rumore torna a posto, ma le resistenze che settano il
guadagno (R13/14) smettono di funzionare, rendendo il tutto un rumoroso e
costoso buffer unitario.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 24/3/2013, 23:24
Infatti quel collegamento che hai indicato in rosso NON deve esserci. Mentre il punto di congiunzione tra C1 e C2 va collegato a massa. Sta cosa mi è sfuggita nello schema precedente che hai postato, me ne sono accorto solo adesso. Tra l'altro, nel penultimo schema c'era un altro errore nel servo-dc che non avevo visto: il condensatore C8 collegato tra l'uscita e l'ingresso + di U1. Naturalmente così non poteva funzionare; ora vedo che hai corretto.

Che vuol dire 'sta cosa:
@Telstar ha scritto:ho fatto due altre prove, ho collegato l'opamp all'alimentazione (a
24V, o anche abbassata), anziché a massa, la fa funzionare meglio.

Non avevi collegato l'alimentazione all'opamp? E come poteva funzionare allora? L'opamp va collegato all'alimentazione duale dell'ampli. E infatti ora che riguardo lo schema precedente, vedo che avevi collegato i due pin dell'alimentazione di U1 a massa... così l'opamp è spento e il servo-dc ovviamente non funziona...

Ricapitolando: elimina il collegamento indicato in rosso; porta a massa il punto di congiunzione tra C1 e C2 (altrimenti C1 e C2 è come se non ci fossero, non possono svolgere la loro funzione di filtro). A massa va anche il punto di congiunzione tra R13 e R14!

avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 24/3/2013, 23:26
Elimina pure R20 e R21 (cortocircuitale) che non servono a niente e fanno solo danni. Lascia invece C3 e C4.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 25/3/2013, 09:22
@bandAlex ha scritto:
Ricapitolando: elimina il collegamento indicato in rosso; porta a massa il punto di congiunzione tra C1 e C2 (altrimenti C1 e C2 è come se non ci fossero, non possono svolgere la loro funzione di filtro). A massa va anche il punto di congiunzione tra R13 e R14!

Ho fatto parecchie castronerie con spice, cmq adesso ho corretto.

Problema n.1 - il rumore è troppo alto, la FFT parte da -74dB
Problema n.2 - collegando il VAS a massa come nel CK2, questo ha creato instabilità nel prototipo (che cmq non aveva i cascode).
Problema n.3 - quale Opa regge 24v? di alimentazione

Confermo che dare un'alimentazione separata a Q2/Q3 non cambia sostanzialmente niente col servo e con tutto il resto.
NB: che non sto operando nessuna modifica sul pcb, e che ne sarà necessario uno nuovo

Quindi secondo me (e anche secondo il mio amico) andrebbe cambiato il modo in cui il VAS dà il guadagno...
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 25/3/2013, 10:24
Scusa, leggo bene sull'ultimo schema la tensione di offset in uscita di -0.6 mV? Ciò significa che il servo-dc ora funziona.

Un operazionale capace di sostenere +/-24V di alimentazione è l'OPA2604 (o OPA604, nella versione singola), quello usato nel Lightning.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 25/3/2013, 13:49
@bandAlex ha scritto:Scusa, leggo bene sull'ultimo schema la tensione di offset in uscita di -0.6 mV? Ciò significa che il servo-dc ora funziona.

Un operazionale capace di sostenere +/-24V di alimentazione è l'OPA2604 (o OPA604, nella versione singola), quello usato nel Lightning.

Si, funziona (al simulatore).
Nel progetto (e in casa) è specificato l'opa2134. Non ho guardato il datasheet ma credo che vada bene. L'importante è che sia a jfet input.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 25/3/2013, 13:54
L'OPA2604 va bene di sicuro, come l'OPA2134. Ai fini dell'applicazione come servo-dc non vi è alcuna differenza, sono entrambi con ingresso a jfet. L'unica differenza è che l'OPA2604 regge fino a 24V di rail.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 25/3/2013, 14:40
@bandAlex ha scritto:L'OPA2604 va bene di sicuro, come l'OPA2134. Ai fini dell'applicazione come servo-dc non vi è alcuna differenza, sono entrambi con ingresso a jfet. L'unica differenza è che l'OPA2604 regge fino a 24V di rail.

Scusa e se riduco la tensione che va all'opa di 6-7V (con 2-3 diodi o qualcos'altro)? Comprometto il funzionamento del servo?
La 2434 ce l'ho in casa, ed anche il relativo socket, la 2604 non ha lo stesso pinout, ma cmq il pcb è da fare ex novo, però quello che mi preoccupa è la banda passante di 20Mhz contro 8. Già a qualcuno oscilla l'opa2134 (poi non so come faccia se NON è alimentata!)...
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 25/3/2013, 14:46
Il 2134 e il 2604 hanno la stessa pedinatura, quella standard degli opamp duali.
Puoi ridurre la tensione che va all'opamp, ma è preferibile usare degli integrati stabilizzatori, magari dei 78/79L15, che sono in TO92 e costano poco, meglio di qualunque zener.
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 25/3/2013, 14:55
@Telstar ha scritto:
@bandAlex ha scritto:L'OPA2604 va bene di sicuro, come l'OPA2134. Ai fini dell'applicazione come servo-dc non vi è alcuna differenza, sono entrambi con ingresso a jfet. L'unica differenza è che l'OPA2604 regge fino a 24V di rail.
però quello che mi preoccupa è la banda passante di 20Mhz contro 8. Già a qualcuno oscilla l'opa2134 (poi non so come faccia se NON è alimentata!)...
Usato in quel modo il 2604 non oscilla di sicuro.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 25/3/2013, 14:59
@bandAlex ha scritto:Il 2134 e il 2604 hanno la stessa pedinatura, quella standard degli opamp duali.

Allora ho letto male i datasheet ;)

Puoi ridurre la tensione che va all'opamp, ma è preferibile usare degli integrati stabilizzatori, magari dei 78/79L15, che sono in TO92 e costano poco, meglio di qualunque zener.

Ho in casa uno stock di 317/313, ma cmq meglio a uscita fissa. Prenderò quelli che mi hai consigliato tu, li ha in stock mouser dove devo ordinare i passivi per il Marsh dopo pasqua.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 25/3/2013, 15:02
@bandAlex ha scritto:Usato in quel modo il 2604 non oscilla di sicuro.

OK ma con 24V di rail sono al limite e per stare al sicuro dovrei ridurre di un paio di volta, a quel punto tanto vale che prendo i regolatori con 15V out.

Il discorso opamp/servo direi che è sistemato, grazie a te :)

Mi restano quei dubbietti di cui sopra relativi al rumore e al VAS con FB in corrente che va a massa, che non piace per niente al mio amico.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 26/3/2013, 17:49
Ho rispolverato un mio vecchio circuito destinato ad un piccolo classe A e gli ho inserito lo stadio finale del kumisa3, con un buon risultato credo.
Guarda queste due FFT (1V in ingresso), quale ti sembra migliore? ;)
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 28/3/2013, 15:37
Indubbiamente la migliore è la prima... è quella del tuo circuitino giusto? cool
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 28/3/2013, 16:00
@bandAlex ha scritto:Indubbiamente la migliore è la prima... è quella del tuo circuitino giusto?

Si, esatto, frontend diverso, e teoricamente più stabile. L'unico problema è che ha bisogno di almeno 35V. Posso mandartelo in mail per avere un tuo parere?
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 28/3/2013, 16:04
Ma certo. Manda pure.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 28/3/2013, 16:22
Ah, e questa è la FFT simulata del CK2 col solo stadio finale EF, con i valori usati nel prototipo NON funzionante (tra l'altro lì le resistenze del bias sono ancora peggiori, ma non so esattamente alla fine che valor ha messo il mio amico).
Il servo in teoria funziona.

Adesso capisci perché gli voglio apportare delle modifiche (sostanzialmente i cascode che vedi nei circuiti che mi hai aiutato a debuggare). La prevalenza di terza armonica è evidente anche qua nonostante i jfet in ingresso.

I valori di default del guadagno sono talmente "starving" che ai finali non arrivava neppure 1mA.
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 29/3/2013, 22:28
@bandAlex ha scritto:Ma certo. Manda pure.

L'ho mandata ieri, ti è arrivata?
avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 29/3/2013, 23:38
Sì arrivata, gli do un'occhiata domani...
avatar
Telstar
mela
mela
Messaggi : 82
Data d'iscrizione : 11.04.12

Re: CK2III per bassa impedenza

il 4/4/2013, 17:34
Allora, mentre ho lasciato a compostare i vari schemi su spice, ho riavuto in mano la mia scheda e sto facendo qualche prova direttamente io.

In primis, ho corretto il VBE multiplier che era 10 volte sottodimensionato per un EF.
NON ho collegato lo stadio finale (anche perché non ho ancora decifrato la basetta che mi aveva fatto il mio amico :( ), e ho semplicemente messo delle resistenze da 39 Ohm agli emettitori dei piloti (che tra l'altro erano già marcate per il CFP sul pcb).

Nella foto allegata si vede il setup di lavoro (con opamp disinserita). I puntali a sinistra stanno misurando l'offset del canale dx, quelli a destra sono V+, V- e massa.
Sul rovescio della scheda sono shortati i condensatorini ceramici e sono modificate le tracce per invertire la polarità di uscita dell'opamp.

Lo schema allegato invece riporta ESATTAMENTE i transistor usati (notare i bipolari in ingresso) e i valori che dovrei avere con 15V.

Al momento ho solo verificato che:
A) la scheda funziona ancora
B) senza servo fino a 9V, l'offset è di una cinquantina di microvolt. A 11V schizza e poi si attesta sui 10 millivolt.
C) Avevo DIMENTICATO di montare l'opa, quindi tra poco riprovo con servo inserito.



avatar
bandAlex
Golden Ears
Golden Ears
Messaggi : 5803
Data d'iscrizione : 29.04.11
Località : Roma

Re: CK2III per bassa impedenza

il 4/4/2013, 20:25
Allora, l'hai inserito l'OPA?
Contenuto sponsorizzato

Re: CK2III per bassa impedenza

Torna in alto
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum