CK2III per bassa impedenza

Pagina 4 di 4 Precedente  1, 2, 3, 4

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da bandAlex il 4/4/2013, 20:25

Allora, l'hai inserito l'OPA?

bandAlex
Golden Ears
Golden Ears

Messaggi : 5068
Data d'iscrizione : 29.04.11

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 4/4/2013, 21:26

@bandAlex ha scritto:Allora, l'hai inserito l'OPA?

Si, e purtroppo le cose non vanno bene.
Come vedi nella foto, non ho shortato gli ingressi, lo faccio stasera/domani e riprovo a misurare l'offset.
Ho preso nota in dettaglio di come si comporta. Ha un settling time di circa 1 minuto (e già questo andrebbe corretto), e già da +-7V di alimentazione inizia a sforare, specialmente uno dei due canali.

7V: -7mV per il canale dx e ben 170mV per il sx.
(nota: servono 8V per far andare 10mA nelle resistenze all'uscita)
9V: 340mV il canale sx e 330 il dx.
12V: 870mv di offset il dx e hmm solo 85 il sx
15V: tra 80 e 90mV il canale sx (sostanzialmente non è cambiato rispetto a 12v),
il canale peggiore, il destro, invece tira fuori ben 1.28 volt.
Non so quanto potrà sistemare il collegamento degli ingressi, cmq lo faccio appena possibile.

Note sull'alimentatore:
Ho impostato un limite di mezzo ampere (per sicurezza), ma cmq il circuito assorbe non più di 70mA con 15V di tensione.
Il ripple è di 5mV e la tensione da un 0,1-0.3V in eccesso.

Note sul servo:
E' installato con uscita come nel kumisa3 originale. Per come ha ponticellato il retro del pcb basta cambiare la piedinatura di 4 transistor per metterlo non invertente come nel CK2.

Dopo queste due prove (ingressi shortati, e poi servo non invertente), in caso di fallimento, l'unica cosa che mi resta da fare prima di rottamare il pcb è di rimettere i jfet, togliendo magari Q5, Q6 e R4 (vedi lo schema nel post sopra).
Altre idee non me ne vengono e il countdown è iniziato :D
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 5/4/2013, 00:40

E luce fu!
Stica quanto cambia shortare gli ingressi!
Il servo finalmente funziona!
Siamo sui 0.15 mV per un canale e ancor meno l'altro.
A 15V regolari di alimentazione (a 11V si comportava stranamente peggio)

Quindi niente cambio di polarità dell'opa. Io aderisco in pieno al motto "se non è rotto, non aggiustarlo" ;)
Però voglio rimettere i jfet in ingresso che sono più silenziosi ed immuni alle varie EMI che circolano in abbondanza nel centro di Milano dove abito.

A tal proposito, il mio amico mi ha consigliato di eliminare R4 (e complementare dell'altro canale) ed eventualmente anche i due transistor li vicino. Cosa ne pensi, Alex?

Per ultimo, domani posterò le foto della basetta coi finali e avrò bisogno di sbrogliarla (ho lo schema ovviamente ma le stagnature non sono chiare come le piste di uno stampato e onestamente non ci capisco una mazza) :)
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da bandAlex il 5/4/2013, 00:49

@Telstar ha scritto:A tal proposito, il mio amico mi ha consigliato di eliminare R4 (e complementare dell'altro canale) ed eventualmente anche i due transistor li vicino. Cosa ne pensi, Alex?

Quali sarebbero i due transistor che vuole eliminare?
avatar
bandAlex
Golden Ears
Golden Ears

Messaggi : 5068
Data d'iscrizione : 29.04.11
Località : Roma

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 5/4/2013, 01:21

Q5 e Q6 nello schema del canale sx.

Io cmq domani provo così:
1) jfet al posto dei bc547/57 in ingresso e nessun'altra modifica, e controllo l'offset
2) rimuovo R4 (senza ponticellare), e ricontrollo
3) indeciso riguardo a Q5 e Q6

Decido quindi cosa fare e passo allo stadio finale. Nota che al momento resterà il bias fisso di circa 10mA per finale, sufficiente nella simulazione a mantenere l'ampli in classe A con 1Vpp in ingresso.

Intanto, questi sono i valori misurati dei jfet (non ne ho altri):

J74BL #1 J74BL #2 K170BL #1 K170BL #2
VGSon @5mA 0,13V 0,13V 0,15V 0,15V
GFS 31,9m 29,2m 24,1m 24,0m
ID 9,84mA 9,91mA 9,83mA 9,70mA
VDS @0 5,52V 5,47V 5,53V 5,63V
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 5/4/2013, 19:50

Suggerimenti su come accoppiare i 4 jfet?
Io pensavo J1 con K2 e J2 con K1...
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 7/4/2013, 12:45

Bah in un modo o nell'altro sono accoppiati come mele e arance.
Tant'è che hanno superato la soglia di aggiustamento del servo e l'offset è schizzato su valori sui 800-900mV per entrambi i canali. Inoltre all'accensione c'è un bump di 5V di continua.

Ho tolto R4/28 (e lasciato il collegamento aperto) ed anche ponticellato le due resistenze del servo da 301k con 10k.
Questo al simulatore ridurrebbe l'offset di 10x, ma in pratica è migliorato solo di poco, 700-800mV.
Piuttosto i 10k hanno migliorato il settling fine del servo e il bump all'accensione sceso a 2V.

Siamo cmq anni luce lontani dal comportamento "da manuale" con i bipolari in ingresso, che quindi torneranno, dopo aver fatto un'ultima prova e cioè invertire due BC per far lavorare il servo non invertente.

Eventualmente potrei aggiustare le resistenze di degenerazione dei jfet, gli offset sono entrambi positivi rif. a massa, quindi teoricamente basterebbe ricalcolare un paio di resistenze.

Al momento non ho né riesco a trovare una quartetta di fet ben matchati, quindi o faccio funzionare la baracca così oppure torno ai bipolari e passo allo stadio di uscita.

Alex hai qualche idea?
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da bandAlex il 7/4/2013, 23:55

Se fossi in te, i fet li lascerei nel cassetto... wink
avatar
bandAlex
Golden Ears
Golden Ears

Messaggi : 5068
Data d'iscrizione : 29.04.11
Località : Roma

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 8/4/2013, 00:30

Stanno per finire nel cassonetto!
Non c'e stato verso di sistemare l'offset aggiustando le resistenze, direi che non c'è più nulla da tentare.

Domani posto le foto della basetta coi finali e vediamo di districarla :)
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da bandAlex il 8/4/2013, 00:31

Bene... wink
avatar
bandAlex
Golden Ears
Golden Ears

Messaggi : 5068
Data d'iscrizione : 29.04.11
Località : Roma

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 8/4/2013, 18:54

Allora,

Non ho ancora rimontato i BC in ingresso, ma lo farò stasera visto che ho deciso di non fare più niente coi jfet, che saranno destinati ad altro uso.

Questo è lo schema completo che rispecchia la scheda così com'è, più lo stadio di uscita:


Sono due i valori di RBias che proverò: 825 che è assolutamente sicura e la sto usando già adesso per le prove con le resistenze, e poi 475 che porterà la dissipazione dei finali a circa 3W l'uno. Il mio amore per le trimpot multigiro è più o meno come quello del diavolo per l'acqua santa :)

Le altre due sono le foto della basetta ancorata al dissipatore per mezzo dei finali stessi.

Immagine 2: facciata superiore della basetta dei finali


Immagine 3: facciata inferiore della basetta dei finali.


E' qui che la mia comprensione tende a zero :( Il circuito dovrebbe cmq rispecchiare la parte finale (incluse le resistenze di polarizzazione dei piloti alla Aloia) e il condensatorino di disaccoppiamento.

Devo capire bene come fare i collegamenti.
-I cavi blu e marrone intrecciati sono le alimentazioni pos e neg
-L'uscita dei finali (cavi rossi) deve rientrare nel pcb del CK2 per andare al servo
-I 4 cavetti, due bianchi e due marroni sono il segnale che entra dal PCB

Infine metto il top del pcb vuoto, che è più leggibile del mio coi componenti montati:
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 9/4/2013, 01:13

Btw, rimessi i bipolari, l'offset si stabilizza intorno a 0,1mV per entrambi i canali, quindi funziona ancora tutto.
Ad ogni modo devonassolutamente prendere degli zoccoli per to-92 che si sono consumati i pad in tre punti e avevo paura non conducesse bene il segnale. Il pcb è un po' malconcio specialmente lì e intorno al l'opamp dove ha smanettato il mio amico.
Dovessi preferire questa versione, è essenziale un nuovo pcb.

Tornando al servo, all'accensione parte cmq con valori altini, non le follie che leggevo ieri coi jfet, ma cmq 100-200mV e diventa accettabile dopo un paio di minuti.
Avevo ponticellato le due resistenze da 301k per trasformarle in 10k circa, ma siccome quando ho acceso oggi con 8v dava i numeri (300mv di offset circa), mi sono girate le palle e le ho tolte.
Confermo che il servo funziona al meglio solo con <7V oppure 15V di alimentazione, coi valori intermedi si impapera. Sarà poca la corrente da qualche parte, non lo so. Cmq non tocco più niente, mi sono proprio stufato.
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 10/4/2013, 23:26

Dopo prove col diode-tester e consultazione con l'amico che ha realizzato la basetta siamo arrivati a questa conclusione (aspetto l'approvazione definitiva prima di saldare):
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 11/4/2013, 22:52

Sistemati i collegamenti (gli ingressi vanno al pin centrale perché i BC americani hanno la piedinatura al contrario, altrimenti il circuito non potrebbe funzionare, e senza finali funzionava).

Il carico fittizio sono 20 Ohm per canale (non ne avevo altre resistenze di potenza).

L'ho acceso. All'inizio l'offset è praticamente inesistenze, così ho portato la tensione a 15V. E' rimasto su pochi microvolt, ma in salita. Lo sto facendo stabilizzare (nella foto dopo circa 3 minuti), e siamo sui 5mV, dovrebbe scendere, dopo tot minuti faceva così con le resistenze fittizie... OK dopo mezzora circa si è stabilizzato e inizia a scendere, aveva raggiunto un picco di 5,5mV per il canale sx e 6.3mV per il destro.
Tra mezzora ricontrollo.

Allegate immagini del setup di lavoro, del multimetro e dell'alimentatore, che ricordo è impostato con mezzo A di limite e ha un ripple di 5mV (misurato con l'oscilloscopio).

SETUP:


PSU:


DMM:
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 13/4/2013, 02:31

Alex ho bisogno di aiuto! :)

Ho messo la resistenza per il bias ottimale nello zoccolo, riaccendo e misuro l'offset che è pressoché nullo.
Tutto bene direi, ma il dissipatore resta freddo. E non dovrebbe, avendo a dissipare 12W.
In teoria.

In pratica il vas di entrambi i canali è in saturazione e non riesce a dare corrente al vbe multiplier. Che non funziona oggi, e probabilmente non ha mai funzionato. Per questo motivo.

I valori che ho misurato sono questi:
Caduta di tensione su R11 e R35: 2.02V (normale)
Caduta di tensione su R14 e R35: 0 (non normale)

Canale sinistro:
Positivo su R12 (sul lato che va al collettore del vas) e negativo sull'uscita che va alla base del finale NPN= 654 mV (dovrebbe essere 800 circa)
Neg R13 pos base PNP 593mV (dovrebbe essere -800)

Canale destro:
Pos R36 neg base NPN = 649mV
Neg R37 pos base PNP = 588mV

Qualche idea, magari evitando di provare senza opamp...
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Al fine scalda!

Messaggio Da Telstar il 14/4/2013, 20:00

Ieri notte, quando era quasi presa la via del cassonetto, ho trovato il problema che era abbastanza imbarazzante -l'alimentatore non forniva il rail negativo senza collegarlo in serie e riferire la massa a questo.

Dato l'alto bias che avevo impostato, ho mantenuto le tensioni a 11V e fatto qualche misura (che ripeterò stasera, alzando poi la tensione a 13V): Non posso permettermi di friggere i finali perché sono gli unici decentemente selezionati su una quarantina di pezzi.
Dopo una mezzora il dissipatore era caldo ma non bollente, quindi c'è un po' di margine, spero almeno fino a 2W/finale.

L'offset è di 0,5mV su un canale e circa 1mV sull'altro, direi accettabile. Prima di passare alle onde sinusoidali e quadre voglio controllare le tensioni che vanno dal VAS ai finali e quella che cade su R23 e R47.

Se hai dei suggerimenti su cosa e dove misurare, ben vengano.

Edit: altra cosa, una volta controllato che tutto è OK e che non c'è rischio di deriva termica, voglio sostituire i BC come VAS e drivers con i 2SA1015/2SC1815 grado Y di cui ho uno stock decente, e dovrebbero essere più lineari a correnti tra 5 e 10mA quali vengono assorbite in quei punti del circuito. Cosa ne pensi?
In ingresso invece non voglio/posso cambiare i 547/557 perché le piazzoline si sono consumate a furia di dissaldare.
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Telstar il 19/4/2013, 17:15

Superato ieri un ultimo scoglio che impediva al VBE del canale destro di funzionare correttamente e decine di misurazioni dopo, le conclusioni sono queste:

-Un bias intorno a 90mA per finale mi sembra un giusto compromesso in termini di potenza, calore e distorsione.
-Tuttavia, il bias fluttua troppo nonostante frequenti aggiustamenti delle trimpot, quindi quei due transistor vanno montati sul dissipatore, non c'è alternativa se voglio mantenere una corrente decente.
-Prova con generatore e oscilloscopio superata a pieni voti per entrambi i canali. Non ho fatto foto per pigrizia, o meglio le ho fatte prima di inserire l'ampli nella catena per avere un riferimento in caso di dubbi.

Mi sento molto meglio che tutte le tribolazioni che ho sofferto, a parte il lato educativo, non sono state vane. Il cassonetto ospiterà qualcos'altro.
avatar
Telstar
mela
mela

Messaggi : 82
Data d'iscrizione : 11.04.12

Tornare in alto Andare in basso

Re: CK2III per bassa impedenza

Messaggio Da Contenuto sponsorizzato


Contenuto sponsorizzato


Tornare in alto Andare in basso

Pagina 4 di 4 Precedente  1, 2, 3, 4

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto


 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum