bandAlex
bandAlex
Golden Ears
Golden Ears
Messaggi : 6926
Data d'iscrizione : 29.04.11
Località : Roma
300714
Lo avevo cacciato via senza tanti rimpianti, e ora ecco che ritorna il fido e caro toroidale di alimentazione, e insieme a lui il solito ponte raddrizzatore e i soliti condensatori di filtro.

Vi spiego quello che è successo, in poche parole (spero).

L'intenzione era quella di eliminare il toroidale di alimentazione, sostituendolo con un paio di moduli switching da 24 V, uno per il rail positivo e uno per quello negativo. E in effetti è con tali moduli che gli unici due prototipi dell'AF-6 tuttora funzionano, quello di Pierpaolo e quello di Stefano (password). E tali prototipi non mostrano alcuna anomalia di funzionamento ormai da mesi. Incoraggiato dai risultati positivi (anche alle misure, che non evidenziavano problematiche di disturbi o interferenze dovute alla frequenza di commutazione degli switching) decisi di procedere con il disegno della pcb prevedendo proprio l'utilizzo di tali moduli.

In realtà, in un paio di casi si sono verificate sul prototipo di Pierpaolo alcune anomalie, risolte in un primo tempo con la sostituzione dei moduli con alcuni di potenza maggiore e poi successivamente ci sono state altre occasioni di anomalie all'accensione dell'amplificatore che però non si sono più presentate successivamente. Ritenendo tali anomalie del tutto casuali e passeggere, non ci ho fatto caso più di tanto.

Dopo l'assemblaggio della pcb arrivata pochi giorni fa, la scheda non ne voleva sapere di funzionare. Eliminato un primo errore di montaggio (un 78L18 montato a rovescio) pensavo di aver risolto, e invece il rail di alimentazione positivo continuava ad oscillare tra il valore di targa di 24 V e un ben più anomalo e basso valore compreso tra i 2 e i 6 Volt.

Constatavo anche come entrambi i moduli switching emettessero un fischio piuttosto evidente, il che mi ha portato a pensare che fossero guasti. Sostituiti entrambi con due moduli nuovi, il problema rimaneva tale e quale, e questo mi ha fatto perdere un paio di giorni alla ricerca di un eventuale errore nella parte della pcb relativa ai due amplificatori destro e sinistro. Inutile dire che tale guasto non l'ho trovato, neanche dopo aver dissaldato gran parte dei componenti e controllato i percorsi di tutte le piste.

Scoraggiato e stremato, ho deciso di eliminare gli switching e di collegare una fonte di alimentazione esterna fornita da una piccola scheda con un toroidale che avevo già pronti alla bisogna. E come per magia, l'amplificatore ha cominciato a funzionare perfettamente.

Ora sto cercando di capire quale può essere il motivo che non fa funzionare correttamente tali moduli switching, e oggi farò un nuovo tentativo rimettendoli al loro posto. Se non dovessi venirne a capo velocemente, ridisegnerò la parte della pcb relativa all'alimentazione prevedendo un toroidale e un classico stadio di rettificazione e di filtro composto da due ponti di diodi e una coppia di elettrolitici.

Vi terrò informati.
Condividi questo articolo su:redditgoogle

Commenti

password
30/7/2014, 17:24password
Dal report di Pierpaolo sembra anche che l'AF-6 migliori con il toroidale.
Comunque non si spiega perché sui prototipi gli switching vadano perfettamente, o almeno sul mio che è acceso molte ore al giorno.
b.veneri
30/7/2014, 17:34b.veneri
Gia', veramente inspiegabile...
Potrebbe essere interessante provare i  nuovi moduli sui prototipi gia' funzionanti, per escludere ogni dubbio...

E poi giu' di toroidale bello pesante ;-)

Grazie Alex, immagino la mole di lavoro dietro questa indagine!
b.veneri
30/7/2014, 17:47b.veneri
Rivedendo le foto del prototipo di Pier Paolo ho notato che i due moduli sono piuttosto lontani dalla pcb; potrebbe il fatto che sono a stretto contatto con il resto dei componenti rendere questi ultimi piu' sensibili ad eventuali 'zozzerie' emesse dagli switching?
Hai provato Alex a distanziarli e collegarli con dei cavetti alla pcb?

Ovviamente, e vorrei che fosse chiaro, non so assolutamente di cosa sto parlando  grande sorriso
bandAlex
30/7/2014, 18:25bandAlex
[Devi essere iscritto e connesso per vedere questo link] ha scritto:Rivedendo le foto del prototipo di Pier Paolo ho notato che i due moduli sono piuttosto lontani dalla pcb; potrebbe il fatto che sono a stretto contatto con il resto dei componenti rendere questi ultimi piu' sensibili ad eventuali 'zozzerie' emesse dagli switching?
Hai provato Alex a distanziarli e collegarli con dei cavetti alla pcb?

Ovviamente, e vorrei che fosse chiaro, non so assolutamente di cosa sto parlando  grande sorriso

Purtroppo il problema è ben più serio che non semplici disturbi, la tensione in uscita dagli switching non ne vuole sapere di stare sui 24 V di targa, ma oscilla casualmente tra valori molto bassi, rendendo impossibile l'utilizzo degli stessi. Del resto, questi moduli sono fatti proprio per essere saldati su una pcb, in prossimità del circuito che alimentano.

Il tentativo di distanziarli con dei fili può essere un test per capire, ma ammesso anche che funzioni, non sarebbe comunque una soluzione al problema in quanto a noi serve che l'alimentazione di +/- 24 Volt sia on board.

Credo che non sia previsto il fatto che questi moduli lavorino in coppia per ottenere una tensione duale, con il terminale negativo di uno collegato al positivo dell'altro. E' probabile che, nonostante essi siano isolati (dentro ciascun modulo vi è un trasformatore che isola la linea di ingresso a 220 V dall'uscita) vi è comunque una corrente di perdita, e tale corrente manda in protezione i moduli prima che questi possano erogare qualcosa sul carico. Se è così (e credo sia proprio così) allora inutile perdere tempo e tornare al classico toroidale.

Resta un mistero il fatto che su due prototipi essi funzionino perfettamente. Magari dipende dalle tolleranze di produzione, chissà.
smanettone
30/7/2014, 18:33smanettone
Magari ti hanno inviato una partita di moduli difettosi. Bisognerebbe vedere se anche altri moduli provenienti da una differente spedizione manifestino lo stesso inconveniente
bandAlex
30/7/2014, 18:35bandAlex
[Devi essere iscritto e connesso per vedere questo link] ha scritto:Dal report di Pierpaolo sembra anche che l'AF-6 migliori con il toroidale.

Alt, non diamo meriti a chi non se li merita.  grande sorriso 

Il miglioramento è senz'altro dovuto al layout ottimizzato della pcb, piuttosto che al cambiamento della sorgente dei 24 Volt.

La prova è data dal fatto che una differenza simile tra il mio vecchio prototipo (che usa il toroidale) e quello di Pierpaolo non c'è proprio. Quindi le differenze all'ascolto dipendono da qualcos'altro che non è legato ai 24 Volt. E meno male, dico pure, perchè altrimenti vorrebbe dire che:

1) la pcb e il layout non contano niente;

2) stavo per far uscire un AF-6 azzoppato dagli switching.

Invece la scelta degli switching era solo pratica ed economica: pratica perchè tali moduli pesano di meno e sono meno ingombranti di un toroidale; economica perchè costano solo 15 Euro l'uno.

Se cade però il presupposto all'affidabilità e alla praticità, allora tanto vale tornare al toroidale.

Comunque non si spiega perché sui prototipi gli switching vadano perfettamente, o almeno sul mio che è acceso molte ore al giorno.

Infatti, ma cercherò di approfondire nei prossimi giorni.
bandAlex
30/7/2014, 18:37bandAlex
[Devi essere iscritto e connesso per vedere questo link] ha scritto:Magari ti hanno inviato una partita di moduli difettosi. Bisognerebbe vedere se anche altri moduli provenienti da una differente spedizione manifestino lo stesso inconveniente

Tutto è possible. E' anche possibile che a furia di toglierli e rimetterli li abbia danneggiati io, a un certo punto.
b.veneri
30/7/2014, 18:53b.veneri
per vedere se sono difettosi i moduli l'unica e' provarli su uno dei prototipi...chi si offre volontario?
password
30/7/2014, 19:00password
Il sospetto che siano difettati è palese, oppure una difformità tra differenti lotti di produzione con caratteristiche di tolleranze diverse.


Comunque il nuovo prototipo suona meglio perché c'è il toroidale... bleh
password
30/7/2014, 19:01password
[Devi essere iscritto e connesso per vedere questo link] ha scritto:per vedere se sono difettosi i moduli l'unica e' provarli su uno dei prototipi...chi si offre volontario?

Il mio non si tocca! fisch
b.veneri
30/7/2014, 19:44b.veneri
[Devi essere iscritto e connesso per vedere questo link] ha scritto:
Comunque il nuovo prototipo suona meglio perché c'è il toroidale... bleh

E pesando di piu' si sposta la frequenza di risonanza dell'insieme mobile-trasformatore-pcb con evidenti miglioramenti nella percezione del nero infrastrumentale bleh  bleh  bleh
Pgragnani2
30/7/2014, 20:04Pgragnani2
Tutta teoria! bleh 

Io lo so quale voglio, senza tante prove! grande sorriso  grande sorriso  grande sorriso
Pgragnani2
30/7/2014, 20:09Pgragnani2
Sti switching avevano rotto il cax!
eisenstein
30/7/2014, 21:28eisenstein
Caro Alessandro,

un po' ben ti sta, così impari a fare il Renzi dell' autocostruzione cuffiofila  grande sorriso 

Ti sia tuttavia reso onore al merito: quando sbatti il grugno, hai il buon senso di tornare sui tuoi passi.
Edmond
30/7/2014, 21:43Edmond
Bene, noi continuiamo ad aspettare..............  fisch  fisch  fisch
Pgragnani2
30/7/2014, 21:57Pgragnani2
[Devi essere iscritto e connesso per vedere questo link] ha scritto:Bene, noi continuiamo ad aspettare..............  fisch  fisch  fisch
Mi sa che bisognerà organizzare un Road Mama 2 in cui lo special guest sia il nuovo AF6.
Pgragnani2
30/7/2014, 21:58Pgragnani2
Direi che Ottobre potrebbe andare......
Dk90
30/7/2014, 22:27Dk90
[Devi essere iscritto e connesso per vedere questo link] ha scritto:Mi sa che bisognerà organizzare un Road Mama 2 in cui lo special guest sia il nuovo AF6.
 band  band  band
alessandro1
30/7/2014, 22:30alessandro1
[Devi essere iscritto e connesso per vedere questo link] ha scritto:
[Devi essere iscritto e connesso per vedere questo link] ha scritto:Mi sa che bisognerà organizzare un Road Mama 2 in cui lo special guest sia il nuovo AF6.
 band  band  band

 band band band band


 essen
Pgragnani2
30/7/2014, 22:37Pgragnani2
essen Come si fa a fare scorrere le faccine?
alessandro1
30/7/2014, 22:48alessandro1
devi usare il tasto "post reply"

poi in alto a destra il tasto con i 3 puntini (more/less buttons)

selezioni la parte di testo che vuoi far scorrere ( o nel caso il cod della faccina) e clicchi sulle freccine che ti sono comparse

 bleh 
Pgragnani2
30/7/2014, 23:10Pgragnani2
grande sorriso 



 grande sorriso
bonvi61
30/7/2014, 23:59bonvi61
band  band  band
bonvi61
31/7/2014, 00:00bonvi61
Per favore i meeting dopo il 20 ottobre, grazie. Se possibile.
Contenuto sponsorizzato
Permessi in questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum.